Raido Quits (2003 CV)

Hi all, Recently my radio has started to quit after a few minutes of operation. It seems to come back on if I turn off key and re-start. Turning
off/on radio has no effect. The sound will occasionally come on for a second or two. The radio/Cassette/CD seems work perfectly except for no sound. I have the factory premium sound system with AM/FM/Cassette/CD.
Any ideas to fix?
What would be required to get a replacement used factory stereo to work?
Thanks, Kent
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kent_Diego wrote:

The actual "radio" in your CV is in the trunk, the interior panel is just a control panel. It sounds like something in the RCU (Rear Control Unit) is causing it to draw too much current and the internal protection is shutting down the unit. In short, a short in the RCU. There's no way to check it out DIY. A local shop "may" be able to fix it, but usually it has to go the manufacturers repair depot for exchange. This isn't a "Ford" facility, but the facility for the company that built the RCU for Ford.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Wrong. There is an actual radio in the dash on the Crown Vic. The Taurus is the one with the radio in the trunk. As far as the original problem, I have no idea. Still under warranty? Take it to the dealer!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Barney Gumble wrote:

Really? I thought Ford went to the RCU across the entire line. I stand corrected.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.