tempo/topaz 2.3L stalling

ive had this prob a long time, the car just stalls when put in drive. VERY intermittent it sometimes happens 5 or 6 times in a row then not again for
several months. does anyone have any ideas, was there a recall from ford for this problem?.our model is 1991 but 89, 90 cars have the same trouble. pretty sure its the electronic ignition system, but the module is too pricey to change on a whim.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You've got a 13-year old car. Don't worry about it.
Be glad it still runs.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

go to google, select search groups, enter this group (or not)
search terms
clean isc iac some of words
will tell you how to clean the Idle Speed controller, Which is right at the throttle body, and where the plastic air feed from filter hooks onto engine
suspect it's gunked after all this time and slow responding
http://www.explorerforum.com/forums/showthread.php?s=&threadid 220 &highlight=cleaning+IAC
{copy & paste ALL}
Is an example... These guys dont know much about cars but the pictures will help you... yours wont look exactly like that but the principles all the same.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.