Slow acceleration for 2002 Focus SE

I just bought an used 2002 Focus SE sedan. I like it very much!
However, every time I went to highway, I found it accelerate much slower than other cars. I had no ideal if it had some problem or not.
Could anyone give some clue before I sent it to autoshop.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What engine. If you have the 2.0 SPI its anaemic. The Zetec 2.0 DOHC is better but not by much.
Did you not test drive the car before you bought it and put it through its paces??
I just bought an used 2002 Focus SE sedan. I like it very much!
However, every time I went to highway, I found it accelerate much slower than other cars. I had no ideal if it had some problem or not. Could anyone give some clue before I sent it to autoshop.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Last year my dealer suggested a complete tune-up on my 2000 SE, which included a cleaning of the intake system. I wasn't unhappy with its performance beforehand, but was delighted at how much peppier it was after the tune-up.
You don't give your mileage, but mine was about 80,000 km (50,000 miles) at that time.
Also be aware that if you have the SPI motor with automatic, they're not the fastest things around, but should be able to keep up if tuned.
Other factors that can affect acceleration: transmission shifting points, soft tires, extra weight in the car.
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Howdy,
Like the others have said, if it's the SPI engine (doesn't say zetec on the valve cover) then it's going to be pretty weak. You didn't mention if this is a manual or automatic transmission either.
Either way, get some new spark plug wires. Take it back to the dealer and see if they will do a diagnostic check for you.
If it is in fact the SPI engine, you're not out of luck. www.focusfanatics.com has a bunch of people in their forum who are dedicated to making the SPI a more powerful engine without paying the high prices for turbo's and such. Check it out =)

http://www.autoforumz.com/Ford-Focus-Slow-acceleration-2002-SE-ftopict123662.html
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"slo" wrote: > Howdy, > > Like the others have said, if it's the SPI engine (doesn't say > zetec on the > valve cover) then it's going to be pretty weak. You didn't > mention if this > is a manual or automatic transmission either. > > Either way, get some new spark plug wires. Take it back to > the dealer and > see if they will do a diagnostic check for you. > > If it is in fact the SPI engine, you're not out of luck. > www.focusfanatics.com has a bunch of people in their forum who > are dedicated > to making the SPI a more powerful engine without paying the > high prices for > turbo's and such. Check it out =) >
> > >I just bought an used 2002 Focus SE sedan. I like it very > much! > > > > However, every time I went to highway, I found it accelerate > much > > slower than other cars. I had no ideal if it had some > problem or not. > > Could anyone give some clue before I sent it to autoshop. > > > > -- > > Posted using the http://www.autoforumz.com interface, at author's request > > Articles individually checked for conformance to usenet > standards > > Topic URL: > > http://www.autoforumz.com/Ford-Focus-Slow-acceleration-2002-SE-ftopict123662.html > > Visit Topic URL to contact author (reg. req'd). Report > abuse: > > http://www.autoforumz.com/eform.php?p `1879
I have almost the same problem with my Focus 2001 ZTS, it wont accelerate fast enough to reach 35mph.. after 35 it runs great... at first I thought that I felt it like that because I was used to 6 cylinders .. but now I really think there is something wrong :cry: ..
It is an automatic transmition, 1 6v Zetec engine (110 k miles)... does anyone have any idea of what could this be? the sad part it is that I just bought it :roll: and have no warranty from the dealer.. I did test drive it but did not notice it at that time :cry:
and I found out just yesterday after taking the car for a long drive that the brakes make some squeaky sound and I also smelled like burned oil or plastic :? I don’t know LOL..
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.