02 Trailblazer clicking after cold start?

Have a 2002 2X4 Trailblazer I have had for just over 2 years. Recently just after starting it there is a clicking sound that comes from what seems to be just behind the steering wheel the sound last for just a
second then goes away it does not do it againd if I turn off and restart nor after driving for a while. It seems to only do it after an overnight stay in the garage or after sitting in a parking lot for several hours. Does anybody have a clue?
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I recently had a noise sort of like that . On a cold start the engine would make a knocking noise . When I first noticed it . It was very slight but after several month it got worse. I finely removed the motor for fear that a piston would come out of the block. But when I tore down the engine all I found was a real bad deposit of carbon on the piston and ring glands. causing the rings to stick and the wrist pin to be to tight . This I was told caused the knock. the tight pin caused the piston to rock in the cylinder bore in tell it was warm. you might try to decarbon the cylinders first before going the way I did.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.