2000 Chevy Impala Base starting problems

Hi: I want to share with those who have an impala 2000 and on. This prob all started last sprring 05. I could use the car,and next time the car went
dead. Had the car towed in twice in one week to the dealer, and they couldn't find the prob.A week later I was driving the car and the key came out of the ignition,so again right away I went back and they said ignition is bad, so they replaced the ignition and this was all done under my extended warranty.I paid only for the towing and a diagnotics fee which was close to $100 something. Also the security light kept coming on. I replaced the battery in Dec. 05, as the battery was a bit weak. Jan 06 the car started doing the samething,security light coming on and car not wanting to start. I had to have road service come out and jump start the car, and then I went to the place I got the battery from and had them do a test on the battery and alternator,they said both were good. Battery was holding a full charge, alternator was reading the correct voltage. Spring 06 the car started to do the samething not start,& security light came on. took it to another dealer as gm reccommended to do so, and still they couldn't get the problem. I was mad b/c that cost me close to$90 for diagnostic on the car.A week later the security light came on again and the car didn't start,so I had wait 15 min & the car started. Next day the samething security light came on,I went back to the dealer I bought the car from,& they saw it and said after they did the computer test,the ignition is bad again. Replaced it for a second time. The car was good till a month or so later & the samething happpened again. The car went dead after waiting it started and was fine. A couple weeks ago samething car went dead, if we push it a little then it seems to want to start. I have called chevy customer service and even sent them an e-mail, all they say is we can't do anything unless you have the car checked at the dealer and I say that the car has been to the dealer. They didn't even want to connect me to someone higher then them. Friday was the last time I spoke to someone in customer service at gm. Last Friday the samething security light came on, took it back to the dealer and said fix the prob, and Monday they called to tell me the ignition went again, and they replaced it.My extended warrenty ended March 06. This now makes it the third time in the one yr that they have replaced the ignition. I told them also that the car keeps going dead and they tested it out and called me back to say everything is good car starts, come please pick up the car. So I picked it up yesterday. I have sent a personal letter to Mr. Rick Wagner President/CEO of GM. So now I will just wait and see what happens next. If anyone has clue or ideas to what might be the prob. Please drop an e-mail to me. Or even want to comment or share their problems with the Impala base 2000 model car. JHK1232
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

We have a 2000 Impala LS that had similar problems. The dealer here replaced the Body Control Module (BCM) and it fixed the problem - but then the new BCM went bad within a couple of days. The BCM was replaced again and all is OK.
Ken
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 2000 Impala LS and the security light has turned on once while driving, but I've had no problems starting the car; and I have had the car since it was new. I read these cars could have this problem with ignition switches and have been prepared in case it happens, but so far so good. Roy

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
To JHK1232 we are having a similar problem with a 97 Buick Regal. It is supposed to be ready today and let me tell you after reading things on-line I am really scared that it will do it again. I have a friend who had this happen years ago. She had her ignition replaced but had the Passlock disengaged. We brought up doing that to our dealer and he did not seem to want to address disengaging it. I also do not understand how Passlock works when some keys have a chip in them and some don't. Does anybody know? The Buick has a key with a chip and my Chevy Blazer does not have a chip in the key.
JHK1232 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to JHK1232, chuck wrote: we have the same problem just started not starting finially we would put the key in turn it to acc. put the shifter in net. and it would start but now it has got to where you have to do it several times when it does start it cranks right up we dont have money to fix this just hope for the best to get to work you would think that a company like gm would man up and recall this problem but it sounds like they dont know how to fix it either and how many of these cars where sold i dont have the resorces to but someone should file a class action lawsuite and make gm pay for all the people who have been stuck in a parking lot saying what do i do now good luck with yours
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.