Auto transmission not shifting beyond gear 2

I have 92 Nissa Maxima. Recently the engine and the computer was replaced. having problem with automatic transmission not shifting beyond gear 2. Whether I keep on D(Drive),2,1 position I see the same
behaviour. It does not shift from 2nd to 3rd gear and I see the RPM rating 4500rpm at 50 mph.
Anybody knows what could be the problem? I appreciate.
Thank you Shak
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I dont know these transmissions, Shak. On American trannies with vacuum modulators, I have seen people put the vacuum line on the wrong port, or even plug it when they forgot where it should go. Result is little or no upshift.
My ol' transmission professor always told me that the very FIRST thing you do after you look at the fluid condition and level, is readjust the linkage. When they changed the engine, it is possible that they disturbed the linkages, but check to see if this tranny has a vacuum modulator and whether the vacuum line is connected and not leaking.
Tell us what you find.
best regards
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ok, if the shifter is in D, and you are at 45mph, when you let off the gas, do you feel engine braking? (i.e. you let off the gas, & you can feel engine drag slow the car) if you put the shifter in 2 and get to 45mph, when you let off the gas you should feel engine braking slowing the car.... if it's in D and you let off the gas in the same situation, NORMALLY you wouldn't feel engine braking. if you DO, then i would say yes, perhaps it's the modulator or a TV cable. you may have a malfunctioning speed sensor somewhere too - stuck 2-3 shift valve in the valve body.... tough call. if when your shifter is in D and you get to 45mph and let off the gas you get no engine braking.... if it feels like it's "coasting", but when you give it gas, it still behaves as though it is in second gear, i would definitely check for a stuck modulator or jammed up TV cable or kickdown cable of some kind. occasionally, a throttle position sensor throwing a bad signal can cause non shifting problems, but usually those will cause no 1-2 shifting too..... not sure about your trans though, it could be different. hope you get it figured out.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.