cruise control problems

1990 chevy 1/2 PU, cruise works most of the time. But once in awhile it will not. I am used to the old cable system. Is there any areas that could have a bad contact. 200,000 miles on truck

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Had a brake pedal cruise control disconnect switch cause this on an earlier model 1/2 ton Chevy PU once. You might see if it's adjusted too close to activation and needs a little clearance. Hope this helps.
Garrett Fulton
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
gfulton wrote:

Thank you I am thinking is something that simple as works most of the time, will see if I can lube that dump switch or adjust it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.ca wrote:

Is what I would call the Dump switch for the C/C a rectangular switch under the dash that rests on the brake arm, or is that the brake switch?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I believe it's the rectangular one. The one I had trouble with, if I remember correctly, was rectangular and was a combination vacuum dump switch and electrical C/C disconnect. Had a vacuum line and two wires going to it. The electrical part was what was causing the trouble, not the vacuum valve.
Garrett Fulton
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.ca wrote:

on mine it's the switch on the turn sig handle. spray some WD40 in it, wipe clean and work it on and off about 20 times.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.