? Fuel problem "86" 4.3 Chevy

I have an 86 El Cameno with 4.3 V6. Purchased some gas that clogged the fuel filter. I have changed the fuel filter. I can't get engine to rev up or
idle, it only runs if pumping accel pedal, but boggs when throttle is opened over quarter throttle. Fuel pump only seems to run for a short time (3sec.) after cranking. Doesn't continue to run with key in on position after cranking. Rechecked filter to see if it had clogged again but it is fine. I used pump as stated above to run about a gallon of fuel into clean drain pan to inspect for dirt, fuel is now clean. Any sugestions??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If debris or contamination got past the fuel filter, it might have gotten into the throttle body passages or into the internal screen in the TBI fuel injector(s)..
--
Robert Hancock Saskatoon, SK, Canada
To email, remove "nospam" from snipped-for-privacy@nospamshaw.ca
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Robert Hancock wrote:

Are the injector screens serviceable by disassembling the injector and cleaning, or do they need special tools to recalibrate such as diesel injectors. Thanks for the reply.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
http://www1.autozone.com/images/cds/gif/large/0900823d8011c799.gif

gotten
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Chris Morda" <1960jeepATdslextremeDOTcom> wrote:

Thanks Chris for the link. The screens are clear, indicated as item 11 in the image.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Rick wrote:

Found the problem. Checked fuel pressure at filter, only had about 3# of pressure. Thought pump had gone bad. Removed fuel tank. Found hose about one and a half inches long between pump output and tank drop tube had a small hole that let fuel spray back into tank. Will reinstall tank tomorrow.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.