Malibu 2004

Suddenly, this morning, the horn on my 2004 Malibu has quit to function. Not only on the steering wheel but also the remote Lock and Unlock functions are
silent. Is there anything a rank amateur could look for and fix?
Grateful for any lead.
Thanks!
Hans
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Start by checking the fuse.

Not
are
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Steve!
(when I said amateur it could have been an understatement...)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hans wrote:

And if the fuse is OK I'd check the connections at the horn itself. You could also tap on the horn while pressing the remote to activate it. If someone had a volt-ohm-meter they could check for voltage to the horn and continuity within the horn itself. The horn relay is another suspect.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I just came back from the dealer, who replaced the burned out fuse. The horn is working fine now! No charge - it was still under waranty.
Thanks all!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.