1987 Prelude 2.0 Si - strange problem...

Hi: I have 1987 Honda Prelude 2.0 Si (Fuel Injection). It is running great. I am having a unsual problem during start up for the past 3 weeks. I start the car in the morning, it starts without any problem. When I
start the car during afternoons or evening, sometimes the car does not start. It cranks and dies immediatly. Then, I have to wait for 2 minutes and then start again, the car starts! If it does not start, I have to wait for another two minutes and then start. Note that I get this problem mostly when the whether is hot. During rainy or cold days, I don't get this problem. When the car has trouble in starting, sometimes I start by holding the accelerator pedal all the way down...and it works sometimes and the car starts...sometimes it doesn't work. Once I start the car, I don't have any problem during driving. Runs smooth. This starting problem is because of some electrical issue? Another thing I noticed is that my horn is not honking...it honks very very low for a second or two. Does this horn and staring have some connection? I took it to mechanic and he is not able to find out the problem. He told me to tune the engine and I did that (change fuel filter, air filter, clean battery, change the connections, change rotor cup, checked radiator coolent level,...). After that, I did not have problem for a week...then, it started again. Then the mechanic changed the ignition coil. But, I still have problem...he is suggesting to change distributor. But, he is not sure whether it will fix the problem. So, I decided not to do that...any of you had similar condition/experience before? Any idea what's going on... Please tell me what could be wrong... man, I love this car, it is very reliable and gas efficient...please help. Thanks a lot. NG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
NG wrote:

tegger.com. main relay.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Jim, I really appreciate it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.