1990 CRX no hot start

Hi All, my friend's 1990 Civic CRX refuses to start if the engine is hot, after a normal drive. When in the no start mode the engine cranks, and it
feels like it is flooded. To start it again, he must open the hood for about 10 to 15 minutes, and without doing anything else, the car would start and run fine afterwards. Any ideas?
Thanks
Arnold
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Arnold wrote:

the Accord from that era. I don't know if it is the same for a civic. Rich
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's the EFI Main Relay!!!!!!
http://www.tegger.com/hondafaq/startproblems.html#mainrelay
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It could be water in your fuel line/gas tank. I had the same problem with my '87 Accord LX-i with EFI. It only happened occationally. Motorweek had recommended using 99% isopropyl alcohol in the tank to evaporate the water, so I did... Up until this point, I have not had the problem anymore.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.