95 del sol problems

recently i've been having some problems with my del sol. at low rpm's the car is sputtering, to me it feels and sounds like it's not getting enough fuel. I
will be driving along fine and then i shift, or i have to go slower, so my rpms go down, and it like chokes, almost stalling out. If i downshift and get into higher rpm it doesn't happen. Also, there is a strong pure gas smell, which i can smell from inside my car the strongest. I figured it would have something to do with the fuel, so i changed the fuel filter, and that didn't help. Today i'm going to change the plug, wires, and air filter. i do regular oil chages (at least once every 3,000 miles), and up to this, i have had no other major mechical difficulties. Any feedback would be outstanding, i'm new to the whole fixing your whole car thing, so i could be going about this completely wrong. Thanks for all your help.
--
solmodifier

------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How many miles on this car? How has it been maintained in the past?
Try all the under-the-hood tips at http://home.earthlink.net/~honda.lioness/id11.html . Start with the least expensive.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.