Crazy idle and no shutdown on a 91 Civic

We have a 91 Honda Civic in which we dropped a jdm vtec engine and ECU in it. You know, the kind of conversion many have done before. But, now we are stuck with the following problem: when we start the engine,
it will hunt between 1K and 2K rpm. Incidentally, the tach only works if you turn the headlight off. On the top of that, we can take the key off the car and it will not shutdown. So, where should I start checking the electrical on this car? We have spend a day testing every wire that goes from and to the ECU and were able to account for each one of them. We have also tested the ECU in another similarly converted car. It worked fine.
Now, I learned this weekend that my friend -- the car owner -- had to cut some of the wires that lead to the bumper/headlight for one reason or another. But he supposedly has soldered them back. However, at this point I wonder if that could have caused the situation and how. If you have not noticed, I am shooting in all directions right now.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Easy to check this one: verify the engine ground is connected. Really weird things happen if it's missing.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Michael Pardee wrote:

    Well, we hunt the grounds down, at least the obvious things. What would you suggest to do next? Incidentally, we have pretty pictures and videos here:http://www.honda-tech.com/zeropost?cmd=tshow&id 51579
--
Mauricio raub-kudria-com
(if you need to email me, use this address =)
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.