02 Hyundai Accent GL - Fast idle problem?

Ok, admittedly i have no clue when it comes to cars, so thought id ask here before my appointment tomorrow at the dealer.
Heres the symptoms: (1) Driving on the highway pretty much stop and go...whenever i came
to a stop, the car just wanted to keep going, when i lifted my foot off the brake the car would just excelerate without having to put my foot on the gas.
(2) Since then the car seems to be working harder, if that makes sense. Takes longer to get up to speed from a stoplight etc...(well longer then usual..yes i know its a hyundai ;})
(3) When at a stop, sometimes the car will *jump* forward on its own.
I did put some fuel injector cleaner in, on advice from a friend, but that doesnt seem to have helped.
any ideas would be much appreciated..
Thanks
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is your Check Engine lamp on?
Check for any DTC's. I'd suspect a throttle position sensor problem. Hyundai had a problem with throttle position sensors on the Accents and Elantras manufactured in 2001 and 2002.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Browner" wrote: > Ok, admittedly i have no clue when it comes to cars, so > thought i'd ask here before my appointment tomorrow at the > dealer. > > Here's the symptoms: > (1) Driving on the highway pretty much stop and go...whenever > i came to a stop, the car just wanted to keep going, when i > lifted my foot off the brake the car would just excelerate > without having to put my foot on the gas. > > (2) Since then the car seems to be working harder, if that > makes sense. Takes longer to get up to speed from a stoplight > etc...(well longer then usual..yes i know it's a hyundai ;}) > > (3) When at a stop, sometimes the car will *jump* forward on > it's own. > > I did put some fuel injector cleaner in, on advice from a > friend, but that doesn't seem to have helped. > > any ideas would be much appreciated.. > > Thanks
Well I took it in, and it turned out that i needed a new throttle position sensor. Everything seems tickity-boo now.
Unfortunately i missed the warranty by exactly 1 week, but they gave me the part anyways, and I just had to pay for labour.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.