Hyundai speedometer

I sold my 2000 elantra to my niece last month and already she is having problems. The check engine light comes on steady and now the speedomoter does not
work. She tells me that she got the oil changed last month and they told her that she may have transmission problems. she thought that they were just trying to sell her something that she did not need. This car is 6 years old and had less than 50k on it. Any ideas? has anybody experienced this before?
Best regards, snipped-for-privacy@booomail.com snipped-for-privacy@bankarea.com http://www.bankarea.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The speedometer cable is probably broken.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Some auto stores will read codes from free. Autozone is one. I would guess it's a O2 sensor?
As for the speedomoter it may be the speedomoter or the speed sensor?
I wonder why they told her why she needs a transmission? I would at this age and milage have the filter and fluid changed if it has not been done. Check the owners manual and see what it says. If it say 100K miles or never do it anyways. Most oil break down, get contaminated and/or acid can build up.
Good luck. snipped-for-privacy@balcanicsoft.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.