96 HOMBRE clutch stuck?

I was driving yesterday and i was accelerating around a corner when right below me (sounded liek transfer case) this wierd buzzing thats slowed with rps started and i had to stop becasue it wouldnt go back
into gear. Once i stopped i could shift to first and be on my way. I thought that the 4wd was tryign to engage or somthing becasue id shift into 4wd than back into 2 wd for the gears to engage again. Okay if was doig that on and off for about a mile the noise would start after i go about 45 then id have to stop and start up again i was on the second mile and all of the sudden it does that again i stop but i cant put it back into gear.
When i shift into gear i dont have to use the clutch while the engine is running, but the gears dont engage.
please help
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If I read you right, you don't use the clutch to put it into gear. You shouldn't be able to do that, it sounds like your clutch may be shot.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.