98 ML430 Stalling problem

Hi,
My mom's 98 ML430 just stalled on her three times today. Twice during ignition and once idling on a stop light. The temperature was warm today - mid 80's to 90's; engine sounds rough; the temperature gauge inside the car
has been constantly at appx. 90-100 degrees. Right before stalling, all the lights on the dashboard would come on and go off.
Has anyone had this problem before? I'd appreciate any input before taking this problem to the dealer. Thanks in advance for all of your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would suspect the overload relay first... it is not that expensive of a part first... If this is cranky, it will shut down the engine on you. My friend with 93 300E did just that all the time... randomly... changed it and all gone.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
we had a similar problem with a 98 ML430 back in 99....it turned out to be a defective battery cable (ground cable i think). At that time we called Mercedes road service and he said it was a known common problem and he even carried the replacement cable.
Don'y know if that is it, but it's worth checking....that would cause you to intermittenly lose all power for a few seconds Chuck
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.