C230 wiper problem

The windshield wiper on my wife's '97 C-230 has begun to start up on it's own every once in a while. I'm afraid that it may be hard to diagnose since
the problem is so intermittent. Just wondered if anyone has encountered this problem before.
-Dick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi,
I had a similar problem on my old Peugeot 307, wipers would wipe maybe once or twice a month. Steadily increased over a year until one day they woudn't stop!
After a month of diagnosing it turned out that some wires underneath the fuse box were getting hot and had melted together over time causing the wipers to wipe!
Matt

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It is probably the signal/wiper stalk... wear and tear... bump it in all different direction and see if it triggers the wiper. When does it do it?
Another possible source is the wiper relay itself on the motor... wear and tear...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I shook the stalk quite a bit and that didn't do anything. I'll try the relay. Thanks for the suggestion.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.