E320 Wheel studs

Just had brake work done on my 1999 E320 wagon and the shop couldn't get the right front wheel off, all the lugs nuts were frozen in place. In fact, in
his trying to get the wheel off he snapped off one of the studs, leaving just four now. He seemed to think there's a Service Bulletin out about this problem, but I can't find one via Google. Anyone have this problem or know of a Bulletin? It's scheduled to go into the local MB dealer tomorrow for them to work on, but it would be nice to know if this is a recurring problem or just something caused by the last repairman.
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

    most likely the problem is your last tireshop. From personal experience I find that they 'constantly' overtighten the lugs when they use their torque wrench.... I don't even let them near my wheels anymore with their impact torque wrench ...... good luck with the removal
cheers, guenter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Agreed.... most shops do this impact thing... is bad and also most place don't even put a dab of grease on the studs too... which will prevent corrosion and seizing from happening.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Had the same problem on 2 studs.Dealer mech.drilled them out .Replaced all studs on 4 wheels @$20 per stud.which are supposed to be new seize proof.

the
in
this
know
problem
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.