Re: 1999 E320 -- engine too hot?

Hi Folks - I could really use your help!! I am experiencing the same problem with my 97 E420. The engine is running very hot and I think that it is causing the Air Conditioning to malfunction. It is a
similiar problem (I believe) to what Laforzaprop has been experiencing! The air blows cold at first - then when the car heats up - the air blows warmer and the system seems to shut down? You can hear almost a hissing sound in the system and it blows warmer more humid air.
I don't think that my auxilary cooling fan is operating properly either?? Is there a relay or fuse for this fan that anyone knows of?
ANY help that you guys could give me on this is REALLY appreciated! I have another appointment on Tuesday to try and diagnose this problem and it is stumping my mechanic! Thanks again folks!!
-KJ-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
how does it do at highway speeds? start cold & stay cold or does it do the same thing?
also are you doing this on a cold motor or a warm motor? the reason i ask is if your doing this on a cold motor and the air warms up you may very well have a heater control valve letting the warming coolant by and warming the AC air. its a long shot.
the case, minus a few cans!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.