Transmission Questions 300TE HELP

Firstly, and a big question. When I went to add tranny fluid level today to my 300TE, someone had inadvertantly put a open bottle of 20/50 Motor Oil in
my Tranny Supply bag. I started adding it to the tranny. Got very little out, maybe a couple of tablespoons or so and noticed what I was doing. I stopped and then added a quart of tranny fluid as it was low. Will that little bit of motor oil in the tranny cause problems? What should I do? I can't believe I was that stupid. I hate to have to replace the filter again as I just did but don't want to trash the transmission.
It seems as though the car has been delaying before going into 1st gear which I know is normal. But at times it doesn't kick down for several minutes and the revs seem to keep high. Also, yesterday I started the car and it wouldn't go into gear until I restarted it and then seemed to work fine. But it was a quart or so low in tranny fluid. I have a slow leak from the pan seal Is this the relay computer causing problems or can it be the need for tranny fluid? The car has 145,000 original miles on the tranny but it has seemed to be fine so far.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A little engine oil in the transmission will do no harm in fact may help some people ad a litre of engine oil to help a older transmission work better this works because engine oil is a little thicker so the pump will pump it better and the seals in the transmission will work better also check your vacuum lines to the modulator valve and also check the modulator valve itself there is a rubber cap that sometimes gets lost

to
in
I
again
from
but
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.