93 300TE ?

I'm going to look at a 93 300TE wagon ,2 wheel drive, 150k mile, garage kept, good body and interior. Owner claims everything works except brake
light comes on once in a while. I'm not familiar with these models and recall Consumers Reports said to stay away from 93s. I drive an 83 300SD with 110K mile and the wifes 87 190E2.3 got totalled a while back. Facts and opinions appreciated.
--

73
Hank WD5JFR



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Brake light that comes one occasionally is most likely to be brake pad sensor... so you need to change the pad. Other than that... sounds good.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is there anything else about these cars with 150,000 miles that can take one to the cleaners?
--

73
Hank WD5JFR
"Tiger" < snipped-for-privacy@hotmail.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
1-104 engine infamous Head Gasket oil leaks 2- AC Evaporator leaks 3-Engine Wire Harness
A few other small things , but these Big three are all very expensive.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a '95 e320 wagon (essentially the same car rebadged). I have already gone through #s 1 and 3. Thanks for the heads up on #2.
Otherwise a great car, though.
Al

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.