A4 V6 2.4 bearing rattle or not

I had the cam belt and all related parts changed in the summer. She has run super since.
Recently, a noise (rattly bearing) has evolved from the unit linked to the
top pulley. It's under the top dust cover, at front, between the cylinder heads. Just below what I can only assume is the spark generator or would it be termed the distributor. Could this be a result of the new timing belt which has loaded the bearings or is it just normal wear/tear. After a few miles/minutes the rattle ceases.
a. Is this the distributor. From past motors they are mechanically attached. b. Could just the bearing be replaced or is it a new unit required. Anyone know approx cost for this part (UK)
Yesterday I did an oil change to a thinner grade, 5W30 (was 10W40) because I thought it was lack of upper head (cam) lub on cold morns.........
ta dj from the UK
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

how about its the power steering pump and low oil........
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 27 Nov 2005 10:49:33 +0000 (UTC), "Juan Hunglow"

Maybe it's the water pump. These seem to be weak on this car.
Mark.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.