Help With 2000 Tahoe/Yukon check engine light

Hi! I have a Yukon aka tahoe. It is a 2000 model. I just had it inspected about two weeks ago with no problems and then all of a sudden yesterday my
check engine soon light came on. I decided to go down to Autozone to have them read the engine codes. I ended up going to two different Autozones and neither could read any codes. In fact, their code readers didn't even reset when they plugged it into my truck. I assume the guys who inspected the car used the port and didn't have any problems. What would cause the port not to be readible? Is there a fuse somewhere that could be bad? On another note, the check engine light is on constantly so I have to assume that it is probably an oxygen sensor that has gone bad. I have not used different gasoline from my regular Phillips standard unleaded so I doubt it is a gas issue. That is unless my wife accidentally putting mid grade in a few weeks ago would make a difference? I have refilled with standard unleaded probably 3-4 times since then. If it is the oxygen sensor, how difficult is that to get to and make that repair myself? What other things typically cause this light to come on?
Thanks in advance for any help or advice.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.