2008 Ford Fiesta 1.4 TDCi - Juddering in idle & kangarooing when driving

Hi, I have a 2008 Ford Fiesta 1.4 TDCi. It's a lovely little car and when it runs smoothly, is great to drive. However...sometimes when driving, at any
speed, gear etc. it will hiccup or jump/jolt and then continue driving. One time the dashboard light which is an orange cog with a '!' in the middle of it came on and stayed on so I pulled over, turned off and got towed home. I took it to my trusted garage who replaced one of the injectors but that has still not fixed the problem. Now in the mornings when I turn it on, the same dash light comes on. I have an OBDII reader with Ford specific capabilities but it is not showing any fault. The light will then eventually go off but the issue of hiccupping still remains. The fuel rail pressure dips by a tiny fraction when it hiccups during driving but no other obvious thing shows up. I can see from the internet that this seems like a common problem with these cars but no one really has any answers on where to start looking for the problem or how to fix it. Any help would be very much appreciated!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi, I have a 2008 Ford Fiesta 1.4 TDCi. It's a lovely little car and when it runs smoothly, is great to drive. However...sometimes when driving, at any speed, gear etc. it will hiccup or jump/jolt and then continue driving. One time the dashboard light which is an orange cog with a '!' in the middle of it came on and stayed on so I pulled over, turned off and got towed home. I took it to my trusted garage who replaced one of the injectors but that has still not fixed the problem. Now in the mornings when I turn it on, the same dash light comes on. I have an OBDII reader with Ford specific capabilities but it is not showing any fault. The light will then eventually go off but the issue of hiccupping still remains. The fuel rail pressure dips by a tiny fraction when it hiccups during driving but no other obvious thing shows up. I can see from the internet that this seems like a common problem with these cars but no one really has any answers on where to start looking for the problem or how to fix it. Any help would be very much appreciated!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to PoorlyFord, Voysey wrote: Hi, I don't have an answer but I think we're having the same issues so I'd like to be kept in the loop with this in case anyone replies. I had a faulty injector and had it replaced last year, now my car is juddering a hell of a lot and I'm at a point now where I can't even drive it far without the juddering and losing all power and the engine light coming on. I suspect it is probably the other injectors that are also faulty, but I'm stumped and super frustrated. If you find anything out, please keep me informed, thank you .
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.