1994 XJ shake/vibration @ highway speed

My 94 XJ shakes/vibrates at highway speed and I can't seem to figure out what's going on. I had a similar problem a couple months ago and
replacing the front drive shaft u-joints fixed it but it's happening again.
I hear a kind of clunking as I speed up and it stops (or I can't hear it anymore) from the front end and occasionally I hear a sort of chirping sound also. I rechecked the front shaft u-joints and they appear to be fine. I recently replaced the wheel hub u-joints. Tires are about 4 months old and have been rotated and balanced regularly. If anyone has any ideas or something else I might be able to check I'd appreciate it. Thanks.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When people describe the sound as chirping, it's going to be a universal joint. If the vibration seems to obsolete, it's be on a driveshaft. Look for the telltale sign of rust seeping from a cup. God Bless America, ill O|||||||O mailto: snipped-for-privacy@aol.com http://www.billhughes.com /
themophead wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is it likely that the front drive shaft u-joints are bad again after about 3 months of highway driving? Like I said, I replaced them not too long ago.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Only you could tell us that. If you put it together without putting a dab of grease in each cup and left the zerk fitting in during assembly, they're dry. God Bless America, ill O|||||||O mailto: snipped-for-privacy@aol.com http://www.billhughes.com /
themophead wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sure, they can fail if the grease didn't get distributed and they can fail if the straps are stretched. The straps stretch easy from vibration and are only a couple bucks to replace.
Mike 86/00 CJ7 Laredo, 33x9.5 BFG Muds, 'glass nose to tail in '00 88 Cherokee 235 BFG AT's
themophead wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like the front hub u-joints again !
Tom T
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Isnt there a ball thingy in the front axle joints assembly cardan that drys out? Mine did years ago but I only heard the chirps at low speed. KH

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, there is a "ball thingy" (I don't know what it's really called) in my front drive shaft and it was completely dried out and extremely worn when I had the shaft out a couple months ago. I'll be taking the shaft out tonight and check that and the u-joints again and see if I can't get this figured out. Thanks for the help.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It could also be a bad track bar. This is a bar in the front suspension that runs across the front of the vehicle and connects the axle to the chassis. If the ball joints on the ends get worn the Cherokee can shake at highway speed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had considered the fact that it might be a bad track bar (and my jeep does need an alignment) but I went ahead and pulled the front drive shaft and the shaking stopped. The centering ball in the cardan joint was completely shot, so I need to get the driveshaft redone. I would do it myself but the post on the shaft that goes into the centering ball is pretty worn so I think my only option at this point is to get a new front drive shaft.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.