Low engine oil pressure when turning left!?!?!

Hey all,
Got a strangle problem that I can't seem to figure out.
1997 TJ Sahara, 4.0L I6.
Got the engine rebuilt recently, and the mech screwed it up. It's burning oil from somewhere, but I don't know where.
All spark plugs seem clean(ish).
After around 2000 miles, there's only around 3 qts of oil instead of 6.
But here's the confusing part:
Even with around 5qts in the engine, every time I turn left, the oil pressure drops to zero. I dropped the oil pan. The oil pickup is on the right side. If anything, there should be MORE oil on the right, when I turn to the left.
Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
6317782 wrote:

Faulty oil pressure sender wold be my first thought. They also leak when they fail. Usually all over the starter.
Check by where the filter is, there is a sensor screwed in there. It has one wire. Normally there is a rubber plug that seals the connector. If it's popped out, that's where your oil is slowly leaking from.
It will look like this.
http://revbeergoggles.com/Fixes/sensor-oil-pressure.jpg
If it is, make sure you get the correct part. One is a switch (for an idiot light) and the other is a pressure sender (for the gauge).
--
DougW



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.