Citroen Berlingo Multispace Instrument Panel

I have a 2000 reg Berlingo Multispace with a dodgy instrument panel. On starting the car all the dials and digital display reset themselves.
They keep turning on and off for a few minutes whilst driving and then the whole panel finally decides to stay on. It will do this for two or three journeys before it finally freezes totally, the dials and the digital display stay frozen on their last readings. To combat this I disconnected the battery and when reconnecting the dials all go back to zero BUT it returns to flicking on and off and then finally freezing again.
I have one theory that it could be due to water getting in somewhere but not sure.
Another point I should make is that there are a couple of parts of the panel that do still work whilst the majority is frozen, that is the air bag light and the headlight display lights. The other warning lights don't work. Such as handbrake, battery, coil light. Because I noticed that the fuse for the instrument panel effects everything on the panel, all of the lights. The fuse was the first thing I checked when it froze for the first time.
Any Help?
Please ask me questions? It's quite a difficult problem to explain, but maybe someone has come across it before?
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
(thekendall snipped-for-privacy@hotmail.com) gurgled happily, sounding much like they were saying :

Unlikely.
Berlingos are multiplexed, so it's almost certainly a computer throwing it's toys somewhere... Time to get it on the fault code reader.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.