2001 Manual 5-speed stalling at idle

I have a 2001 5-Speed (manual) Maxima SE. Every time I stop at a light and put the car in neutral, the rpm's drop to under 500 and then
stalls. The car will re-start right away, but if I don't keep slight pressure on the gas to rev the engine, it will re-stall. My car has 109,000 miles on it. I was told that I may be low on transmission fluid, but as of yet haven't found a way to check in my repair manual. Any help/ideas?
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 06.02.2007 21:32, snipped-for-privacy@gmail.com wrote:

Could also be something in motor management that deals with idle engine control. Maybe some sensor (lambda sond?).
Kind regards
    robert
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have the same problem on my 1995 manual with 126,000 miles. also, when i am in 1st,2nd, or 3rd, occasionally the car will jerk violently.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If it hasn't had a tune up in the 109K, it could be as simple as a new set of Spark Plugs and a fuel filter. Also, could be fuel pump going bad.
maxima
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.