2000 Pontiac Sunfire

Hi, My 2000 Pontiac Sunfire has, for the second time, had the check engine light come on solid (not flashing). It does seemed to idle a little rough and
seems to almost miss a little when you are driving and just barely pressing the pedal. Could this be caused by the fuel filter? I have 54,000 miles on it and have never changed the fuel filter. If so, does anyone know how easy or difficult it is to remove and install a new filter? Thanks for any advice.
--
Kevin Johnson



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what he means to say is if the thing's clogged, it won't run. period.
Steven
| No. | GW | | Kevin wrote: | | > Hi, | > My 2000 Pontiac Sunfire has, for the second time, had the check engine light | > come on solid (not flashing). It does seemed to idle a little rough and | > seems to almost miss a little when you are driving and just barely pressing | > the pedal. Could this be caused by the fuel filter? | > | > -- | > Kevin Johnson |
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

light
pressing
easy
IAT sensor... if its unplugged or bad it'll throw a check engine light and the car will act funny.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.