2006 Subaru forester x (premium) not getting power to my climate controls !

Hellow everyone, I have a problem with my climate controls not getting any power/or possibly not sending any power.. I've replaced the circular blower
motor relay, and every fuse in the car.. I'm currently in search or another relay that could control the controls. But I'm have trouble locating it (If it exists). Any body have any ideas? Or know of a solution? Please help, winters coming and I have no heat or defrost!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 9/7/2016 11:18 PM, Matt wrote:

Their was a Russian website which I failed to bookmark that had a lot of Subaru detail shop manuals in English. Maybe you can find them.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to Frank, Matt wrote: Thanks frank, I'll check it out!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 9/8/2016 5:17 PM, Matt wrote:

That site may be down as I thought I had bookmarked it. Cursory google look did not show it. I may have mentioned it in this ng years ago. Others will sell them.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.