Cadillac Transmission

I've got 2 different answers from 2 different mechanics so hopefully you all can shed some light on this problem. 94 Cadillac Seville STS 163,000 miles (well maintained/regular service
visits). After 5 minutes of driving, the transmission will no longer shift automatically and I'm forced to shift manually through 1-2-3 gears. The speedometer & tach both work fine the entire time. First mechanic said it was the input speed sensor which needed to be replaced and quoted me $280-$300 to install it. Second mechanic said the entire transmission was shot and needed to be replaced. (Which doesnt make sense to me, because if thats the case then why can I shift manually?). The check Engine light is also on which leads me to believe maybe it is indeed the input speed sensor or something electronic and not the tranmission. (Unless theres some sort of emissions problem also leading to the check engine line).
Any ideas? I'm going to take it a 3rd mechanic this week and get another opinon....
Thanks! -Greg Kaiser
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Go here and do a search for solenoid. It's an olds aurora forum, but auroras also run the 4t80e transmission. http://townhall-talk.edmunds.com/WebX?50@ snipped-for-privacy@.ef429a!make=Oldsmobile&model=Aurora&ed_makeindex=.ef0429a

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.