camry, speedometer dead, "O/D off", engine noise when turning

Mine is a 1987 camry 4 door sedan. Sometime the speedometer stop working (pointing to zero), then it may start working by itself. When the speedometer stop working,
"O/D off" (meanes over drive is off) flashes on the small panel below the speedometer, though the over drive button is pushed into "on" posision and I can feel it's on when driving. What's the problem?
Another thing: When turning direction at low speed, the engine noise getting very loud. Is there anything wrong?
Thank you for your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Frayed speedo cable? OD off? no idea

Could be wheel bearings, CV joints, power steering rack.... Lots of expensive things..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Cable need lubing. But you need a mechanic as I guess alot mor needs help
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What do you lube the cable with? Grease, spray, graphite?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's probably electronic - fed by wires from the vehicle speed sensor on top of the transmission housing. Check the electrical connections there.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.