metal noise on startup

I drive a 1998 Volvo S-70 with just under 300,000 miles. Within the past 2 weeks, upon start up I get this almost metal on metal sound. Giving it mo
re gas doesn't change the speed of the sound so I doubt it is engine relate d. When I turn the engine off and restart it goes away. I have had some is sues with the AC going off and after turning that and the fan off for a cou ple of minutes I have AC again. I'm thinking that might be the culprit, th e Compressor but want to ask if anyone else has had a similar issue and if so how difficult is it to replace.
Thanks in advance!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Denny A posted for all of us...

2 weeks, upon start up I get this almost metal on metal sound. Giving it more gas doesn't change the speed of the sound so I doubt it is engine related. When I turn the engine off and restart it goes away. I have had some issues with the AC going off and after turning that and the fan off for a couple of minutes I have AC again. I'm thinking that might be the culprit, the Compressor but want to ask if anyone else has had a similar issue and if so how difficult is it to replace.

This is hard to diagnose from afar. Take a long screwdriver and press it against the part you think is having the problem and your ear. Use caution doing this! If it is the compressor replacement is just one step. The system must be evacuated of all refrigerant, maybe flushed, other parts replaced, vacuumed and re-pressurized. It is really not a DIY job for one without the equipment.
--
Tekkie

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 18/07/2018 18:46, Denny A wrote:

Could it be the compressor drive belt slipping? Have you checked the belt tension? What happens if you start the engine with aircon turned off so that there is no load on the compressor and belt?
--
Cheers,
Roger
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.