help plz..Brake lights do not work now

2001 Trail Blazer
My brake lights have quit working and was wondering if anyone can help me get them to work again.
I have checked the fuse and the blubs.
Thanks for any replies
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I don't know if this is the case with yours, but it may be:
The brake lights in my truck are also my rear turn signals. So if I put my left turn signal on, that's my left brake light. The same goes for the right. So if you put your left or right turn signal on (don't forget to put the key to accessory), do the lights flash?
Try the 4-way/hazzard lights for the same reason.
I had a problem with my turn signals (front&back), parking lights, 4-way/hazzard, and stop lights all were blowing their fuses -- but not the bulbs. It ended up being the trailer light harness was corroded and shorted out.
Just some odd ideas -- it's a newer truck so I would be suprised if it was corrosion -- unless you were playing with something ;)
-Joe

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry all , here some more info
Also the turn signals work and the Haz flashers work.
When stepping on the brakes the light on top the truck above the back windshield works as it should.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like a problem ive heard of with the turn signal/multifunction switch. Not a cheap proposition unfortunately
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The boards you are talking about are they in the taillight assembly, called the service center and had to set an appointment because they have never heard of this before and may need time to figure it out.
No, over 36000 miles.
On Mon, 04 Aug 2003 09:13:33 GMT, snipped-for-privacy@hotmail.com (Old Crow) wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Old Crow
There is no board on this 2001 Trail Blazer just sockets where the blubs fix into.
The 2001 TB is like the old Blazer befroe the body change maybe that is the problem
On Tue, 05 Aug 2003 09:16:46 GMT, snipped-for-privacy@hotmail.com (Old Crow) wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
probably the big fuse for the stop lamps, I think it was hidden in glove box on the S10 blazers and underhood for C/K trucks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.