98 2.8 A4 Cruise and CD changer problems

Hi,
I just bought a 98 2.8 A4 and its cruise control won't engage now. It engaged once or twice when I first got it, but now it never engages. I can hear a relay like sound coming from roughly the top center of dash
when I try to engage it so I know the stalk is making a connection. I don't have the owners manual (on order) so I don't know what fuses / relays control the cruise functionality. Could someone provide me this information or possibly some other trouble shooting advice?
Also the car has the upgraded Bose stereo with the 6-disc changer. The problem is that the stereo always reports an error such as "CD01 - ERR" whenever I switch the mode to "CD". Yes, I tried putting the CD in both ways to make sure I didn't have it placed upside down in the cartridge. Again any advice on the matter would be greatly appreciated.
Thanks for now. I'm sure I'll have other questions later :)
-Marcus
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 28 Mar 2005 12:50:38 -0800, snipped-for-privacy@hotmail.com wrote:

Try this: slide the arming switch back and forth full-stroke a bunch of times - like 20 or so. See if the cruise works more reliably now. btdt.

If it only happens with burned discs, try a pressed CD. If it happens with pressed CDs, could be a crapped out laser assembly, or just a lot of accumulated dust. Pull the changer and gently blow out the bunnies and see where that leads.
When I get a CD01 it's usually because a dog hair found its way into the cartridge when I had it in the house...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.