Brake Lights Problem

I drive a 1998 A4 1.8T and when my headlights are on my brake lights do not work. The thrird brake light does work but the other two dont. Anyway if anyone has had this problem or something similar and know
how to fix it that would be awesome. I really want to avoid taking it to the dealer because they will charge me up the ass. Thanks
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just make sure you are using the correct bulbs in the brake light sockets. If the sockets are for both the taillights AND the brake lights maybe the bulb is not installed correctly or is the wrong bulb.
Do those brake lights ever come on or are the bulbs burnt out? fuses?
Just a theory! ;-) later, dave (One out of many daves)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TCC - you might take the money out of the place where the sun don't shine that the dealer would have charged you and invest in a set of Bentley Manuals. The wiring diagrams are your best friend in troubleshooting electrical problems - that's what the dealer's techs would be using. This problem sounds like the wiring problems I used to have on my 1980 5k - turn signals would activate the dash lights (solution: corroded front parking light/turn signal socket), or on my 1987 5ktq - no dash lights (solution: incorrect licence plate bulb wattage). The Bentley Manuals helped with both cases. Cheers! Steve Sears 1987 Audi 5kTQ 1980 Audi 5k 1962 and '64 Auto Union DKW Junior deLuxes (SPAM Blocker NOTE: Remove SHOES to reply)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"TCCdestroy" wrote:

I tried replacing the bulbs and the same problem occors, the fuses are good although it might be wired through some strange circut...but everything else seems to be working.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TCC, Dare I ask......do you have a trailer hitch on the car? It sounds like a problem with the parking light/brake light circuit - you'll probably find a problem where the two meet - like in a 1157/2057 light bulb socket. Cheers! Steve Sears 1987 Audi 5kTQ 1980 Audi 5k 1962 and '64 Auto Union DKW Junior deLuxes (SPAM Blocker NOTE: Remove SHOES to reply)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.