1993 518i

Hi, Can anyone help me in the wilds of northern Scotland. I am having problems with this not starting or cutting out. It may be an immobiliser problem as there is plenty life in the battery etc and before cutting out
i notice the radio/cd cuts off first. It was happening a few weeks ago and i switched off the alarm using the key and all was ok for a while, but the problem is back,and still intermittent. No decent auto electricians or garages up here who seem keen to take a look, can I isolate the immobilser further ? Please please please help !
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Andy Cruikshank in the Carse industrial estate of Inverness is the best local independant. Where are you?

It could be a bad relay. On the E24/28 there was an unloader relay involved in power distribution. I've seen that cause problems. Not sure if the E34 has something similar.
Any other symptoms?
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
just a note of thanks to the forum and especially john burns who replied, problem now cured with a 29p part from Calterdon BMW in inverness, that includes VAT !!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.