1997 528i Cruise @ airbag

When we first got the car we could not turn the cruise on via the I/O on the steering wheel - had to use a button on the dash. (factory) Now while driving along the cruise will turn off. When it turns off the red
airbag light in the dash will come on. The cruise will not re-engage, even with turning it on and off. Once the car has been restarted all is well until it repeats.
Stereo controls on the other side of the steering wheel work fine - not sure if it is a problem in the steering wheel or somewhere else.
Anyone have any similar experiences/ideas about this?
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Think that's normal to activate it for the first time on a journey. It's how mine works.
--
*Husband and cat lost -- reward for cat

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
At least that gets part of the question out of the way! My 01 only has the cruise on the steering wheel - the whole steering wheel/dash button deal threw me off.
Now if I can figure out the air bag light and why the cruise just quits all will be well!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.