E21 Oxygen Sensor Light

Hi all,
I just purchased a 1981 320is with only 79K miles on it and replaced the O2 sensor yesterday. It wouldn't surprise me if that was the original O2 sensor. Unfortunetely, it didn't extinguish the light on
the dashboard. Is there a special button to press to get it to reset, or is it supposed to be automatic? My owner's manual seems to imply that the light with go out when the sensor is replaced. The other issue I have is that the car idles a bit high, around 1200-1500rpm. Just for the hell of it, I unplugged the new O2 sensor to see what the engine would do. It dropped back down to around 900rpm. It went right back to 1200-1500rpm as soon as I plugged it back in. I can't seem to find any vacuum leaks anywhere and all the other sensors look good. Is this just a matter of adjusting the idle set screw? I haven't checked the ignition timing yet though. Any suggestions on resetting the O2 sensor light and the high idle? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Here's a thread that might be of help... http://forums.bimmerforums.com/forum/archive/index.php/t-84591.html

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.