Rough idle on '90 BMW 735il

I have a 1990 BMW 735il, and it has recently developed a rough idle problem. If the car is cold it will idle just fine - for a minute or two. Then the idle will become very rough, requiring me to give it gas
(sometimes quite a bit) to keep the engine running. Moreover, the car has no power during this time unless I give it quite a bit of gas. The Check Engine light will come on during this time as well. Once the engine is fully warmed up the engine idles more smoothly, but it's still not that smooth.
I've had this car looked at by a couple mechanics, and so far they haven't been able to figure out what's going on. Does anybody have any idea what's wrong? I don't see any white smoke coming out the tailpipe, and it doesn't look like the oil and coolant are mixing, so it doesn't appear to be a fauly head gasket or cracked head. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

M30s are always a little agricultural at idle.
It's possible you have a small vacuum leak. But if the distributor and rotor arm are ancient I'd replace them. New plugs might not hurt either (Bosch single electrode).
If the car hasn't had a valve adjustment in the last 30k miles I'd rectify that.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.