Speedo wobble in ZX

Does anyone know the cure to stop my ZX speedo needle wobbling? Could it be a duff cable? It's on a ZX Reflex 1.9D.

--
Tunku

"end user" v. A command regrettably not implemented in most systems.
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
could be, or could be speedo head as well. just get a cable and see if that cures it, always try the cheapest option first :-)
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Bloody hell, the top part of the speedo cable doesn't half do some bends eh? I reckon that is the problem, the thing has worn due to the extreme bending it does. Now to get one, and worse, try to fit it !
--
Tunku

"end user" v. A command regrettably not implemented in most systems.
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
worse part is fitting it to speedo head after doing all that routeing, not much slack and not much room.
Much easier to fit speedo side first but even knowing its a pain i always forget and end up cursing myself.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.