1996 Dodge Ram 2500 diesel

Hi, guys, I have a problem with my 1996 dodge ram 2500 with the cummins diesel. It started about 2 months ago and I have not been able to pinpoint it. It did happen about 3 yrs ago but only lasted 2 weeks and everything
worked good till 2 months ago. It is an intermittent problem, worst when I have a load or the engine is working harder or on bumpy roads. It does not do it while idling. Here goes the description, the worst problem is the tack jumping up and down, usually down and back to normal but sometimes lately it will go up in the red line zone. If it is really bad the speedometer also jumps up and down. The rest of the problem , are lights coming on when they should not, the engine light, the gen light, water in fuel light, wait to start light and the cruise control comes on. I cannot use the cruise control because it keeps going off.
The only visible problem which I sprayed with corrosion X, an aircraft anti corrosive that is excellent for electrical problem, was a little green deposits on the center plug of the computer behind the air filter. I am starting to believe it might be a heavy wire on the alternator bracket, I believe it is the sensor for the tack and cruise control. This unit was taped but it seem like it has gotten hot and most of the tape has fallen off. Other than the tape, the rest of the unit looks in perfect condition.
Any suggestions? Thanks Eric
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Wish I could help. I have the same truck but haven't experienced this. John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.