rough or no idle 89 dakota

engine was pressure washed a few weeks ago to clean the off that was leaking from the valve covers. Ran fine up until then. Now it will rough idle when parked and not at all when in gear. I have replaced the cap and
rotor, plugs and wires. Also put stp gas treatment in tank to help with any water in gas. What else can I do? Thanks, Scott
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

clean and blow out any electrical connectors under the hood. make sure the pressure washer didn't break any vacuum hoses or connectors. make sure nothing got unplugged during the pressure washing operation.
--
----------------------------
-Chris
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Turns out the computer short circuited from water getting into it. $240 + labor to fix.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Remind me never to pressure wash a computer.
Thanks for the field report. I spilled some water into my desktop computer key board the other day, and it didn't work right. Had to take it apart (not too dificult). Dry it out with paper napkin, and the next day it was working again.
--

Christopher A. Young
You can't shout down a troll.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.