Cinquecento misses

I have a '97 Cinquecento S and I seem to have a problem with the engine. Lately when I've been driving the car, it seems to be jerking as if one of the cylinders isn't firing, also a red 'injector' light appears on the
dashboard. I've changed the plugs today for starters but it still seem to be doing the same thing. It's not happening all the time, just sometimes.
Any suggestions are welcome.
--
Lee
http://www.bradford7.co.uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Could be the coil or a broken plug lead. Also if it has fuel injection it could be numerous things including a dodgy injector or one of the multitude of sensors. Try a dealer and ask for a "diagnostic with examiner" on it. About half hours labour approx. HTH Iain.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, also posted in the uk.rec.cars.maintenance NG, someone there suggested the coil pack. I bought another one today and fitted it tonight but the problem is intermittent so I'll post back in a couple of days and let you know how it went.
Cheers
--
Lee
http://www.bradford7.co.uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Had a similar problem with my Brava. It needed a replacement ECU after the car would not start one day after a similar intermittent fault. Start saving! Iain.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.