1993 Ford Taurus - Cruise Control and Turn Signal Out Today >.<

Hello All:
1) My cruise control went out today and just quit while in use today. It doesn't work anymore.
2) My turn signals also went out today and I was wondering if there was
some kind of connection. I'm not sure if it went out with the cruise control but I'm pretty sure these malfunctions are purely coincidental.
Does anyone have a fuse box diagram for the 1993 Ford Taurus or have any clues as to why these things are broken?
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Zec wrote:

Check your brake lights too, then replace the blown out bulb(s).
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bulbs eh? All of them? Is it known that they all blow at the same time? Is it hooked up in series or something?
trainfan1 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Zec wrote:

Bulb(s). Just the brake light bulb that's blown.
Is it known that they all blow at the same time?
Highly unusual, but will if shocked(water,etc.) or by coincidence.

As a matter of fact, yes.
Rob

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Do you have a tilt steering wheel? Chances are one of the wires in the steering column has broken from flexing.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Okay... I know you all will think I'm crazy but...
...the solution to my cruise control and the turn signal problem was just to toggle the hazard light. Must have been stuck halfway or something. Funny that the cruise is connected to the problem.
The problem: I flashed it to thank a truck driver who slowed down as I passed him on a two lane highway and of didn't need to use my turn signals for another 100 or so miles. Well, shortly after the hazards, the cruise goes out and apparently, my turn signals also.
Now you know that this can cure this problem! Hope it helps. Thanks for all your help!
-Zec
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Zec wrote:

That'll do it!
Thankd for coming back & telling us what the solution was.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Very likely the multi-function switch (does turn signals, flashers, wipers) is getting flaky. They eventually fail and have to be replaced. Of course, now that you know the cause, you can probably get by for quite a while just by working the switches once in a while or whenever things stop working. I have to replace the switches in both my '93 and '95 one of these days...
PoD

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Zec wrote:

Cruise control can be a number of things, maybe clockspring in wheel or switch or servo, etc, or even related to the TS problem.
If the turnsignals just quit, it's probably the MF switch at the steering column.
get a $2 fuse tester and start testing the fuses, or INVEST in the EVTM for the make & year. The source: www.helminc.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Are you sure it's the turn signals and not the brake lights? Brake light failure combined with Cruise Control failure is the common symptom of a bad brake (aka BOO) switch.
CJB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

    Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.