98 Grand Marquis Hard Starting and low idle speed

My Grand Marquis is acting up again. It is difficult to start and when it does it idles very low and almost stalls. Afer a few minutes it's okay but after it warms up and I'm on the highway, it pings.
Last year I replaced the idle motor because of similar problems. If it's the same problem,can expect to replace this part every year? Anyone know wat the hell is wrong with this car? M
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Pinging is likely due to a dirty MAF.
It's not inconceivable that a cheap version of the Idle Speed Control would hang up.. bad luck, sure but not real rare, I'd think. Where did you get it?
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for your reply. I'm no sure what the MAF is. Is it the air filter? The idel speed control was replaced by my mechaninic and I assume it came from a decent auto parts distributor.
M
On Thu, 28 Sep 2006 02:55:14 GMT, Backyard Mechanic

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's located between the airfilter and throttle body. It measures air mass into the engine for mixture tuning purposes. If it's dirty it will give a false low reading, which will result in less fuel to actual air, thus lean, thus ping. USUALLY dirty MAF has little to no effect on idle speed, but may cause stumble on acceleration from idle under load, like at a light.
Idle speed control only controls the engine speed by adjusting air admitted till speed is correct.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mstrspy wrote:

The MAF (Mass Air Flow) is located right behind the air filter. On my 1999 Grand Marquis LS, it's right behind the square plastic box, on the driver's side.
Yours should be in the same location.it's a plastic pipe going to the engine's intake, and has a connector on it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Found it. Thanks M
On Fri, 29 Sep 2006 21:33:42 -0400, Starscream

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mstrspy wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.