99 ford expedition

it has been parked for about 8 months. it was running fine before it was parked and now it wont start. it acts like its not getting any gas. (did put gas in it). please help

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Do you hear the fuel pump as you switch ignition on? Should cycle on for two seconds.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
being that i am a woman, im not sure if i hear a fuel pump. i did put my hear on side of truck by the gas tank and all you hear is something that sounds like metal taping metal nothing else
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

it sounds like your dishwasher when you first start it.. but much lower volume.. and no sloshing, just "-m-m-m-m-m-m-".
and only for one or two seconds..
meantime look at you r owners manual and find the part about the inertia or collision disable switch.
It may have been bumped. Should be in a rear panel of the vehicle
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i will look for that, i did look in the book i did read something about a fuel cut off switch, i found that and it was okay. i did not know about the other button. im crossing my fingers
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.