GEM module queation

I have a 2000 Taurus SEL that the windshield washers and the wipers in the high posiiton will not work. No one replied to this question I posted in this NG a month ago. My Taurus has 77000 miles on it, everything works fine
with the exception of the wiper and washer issue.
The multi-function switch was replaced, and that did not remedy the problem. My friend, who runs a service shop, looked at my problem, traced the wiring for two days and came up with the following conclusion;
The washer pump works with a separate power supply The wiper motor works in all speeds with a separate power supply The multi-function switch works in all of it's functions
He diagnosed the problem as an issue with the GEM module, a part available to his shop, but not able to be "burned" with 2000 Taurus information, as this information is the property of Ford Motor. My tech says to take my car to the local dealer for the GEM module and programming.
I recognize a lot of wisdom in this NG and would appreciate any input on resolving this issue before I call the dealer on Monday.
Thank you in advance
Frank from Deeeetroit
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Frank from Deeeetroit wrote:

There are aftermarket scan tools than can program a gem if they buy the subscription. It might be tough finding an independent that has one though. Considered a junk yard one? I believe its behind the IP on the taurus.
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.