No heat, '87 Mercury Sable

Does anyone have advice for the following problem.
* Occasionally (10 times per month), there will be NO Heat available inside the car. The blower always works fine, but will the air will
be cold. One day things work fine, and the next day no heat.
* The engine temp does not overheat. Therefore, I do not supsect water pump. Also don't suspect thermostat becz even after 30 minutes of driving, there will be no heat at all.
* Recently had a new heater-core installed becz it was leaking.
Can this be a blend-door actuator motor problem? I can hear this motor when cycling through the digital thermostat settings. But I have not had the chance to listen for the motor when there is no heat. I'm guessing this unit is in the dash, center area, near the firewall?
* Also, there is another motor or flap sound that I can hear and see when looking above in the glove box. When I turn the temp system off, this motor of flap engages. Not sure what this is?
I really don't feel like sending this car to Ford and spend $500. Any tips, advice, or self-checks I can perform? Has anyone else had similar problems?
Much thanks.
--
Jim.
jgurney snipped-for-privacy@hotmail.com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jim, Could be a lot of things, since the core was replaced recently, you may have an air pocket. You didn't mention what engine you had, but the 3.8 requires a little know how. Who did your heater core? Why not bring it there? Could be the control system, that requires a little more know-how to diagnose properly. Also, that's a dealer, not Ford, two different things. Also interesting that people know where they could bring it to get it fixed, but don't want to pay for it. The days of grease monkey's are long gone, and if you want quality work, you should be willing to pay for it. I don't work for a cut rate, and I don't expect any one else to.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.